US Platform 1: Degraded Performance
Incident Report for Qualys, Inc.
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 08, 2019 - 08:01 PST
Monitoring
The rebalancing process for the storage array has completed and performance has stabilized across all services. We will continue to monitor closely.
Posted 2 months ago. Feb 07, 2019 - 19:38 PST
Update
Our engineers have implemented mitigating factors to relieve the impact caused by storage rebalancing. At this time, performance has returned to within range of normal operations, and continues to be closely monitored. The remaining impact to the platform is now a backlog of events for Cloud Agent VM and PC processing. We continue to work around the clock to fully restore service. Further updates will be provided as new information becomes available.
Posted 3 months ago. Feb 06, 2019 - 20:13 PST
Update
Our engineers have completed initial steps to minimize the impact while on-going progress is made with the underlining storage rebalance. However, until fully completed, users may continue to experience minor performance degradation impacting general workflows such as: browsing the UI, Report generation, Scan Processing, Agent processing, and API. Further updates will be shared as they become available.
Posted 3 months ago. Feb 05, 2019 - 16:26 PST
Update
Our engineers continue to work with the storage vendor to optimize the process currently having an impact on general performance. Steps are being taken to minimize the impact, however users may experience minor performance degradation impacting general workflows such as: browsing the UI, Report generation, Scan Processing, Agent processing, and API. Further updates will be shared as they become available.
Posted 3 months ago. Feb 05, 2019 - 11:13 PST
Identified
The primary storage used by the primary database and other services has experienced a disk failure. Our engineers are working with the vendor to mitigate the impact. Rebalancing is currently in progress and general performance may continue to be impacted until it has fully completed.
Posted 3 months ago. Feb 04, 2019 - 20:11 PST
Investigating
Qualys Cloud Platform Operations is currently investigating an issue causing degraded performance across all services. Further updates will be provided as they become available.
Posted 3 months ago. Feb 04, 2019 - 16:15 PST
This incident affected: US Platform 1 (Cloud Agent (CA), AssetView (AV), Vulnerability Management (VM), Threat Protection (TP), Security Configuration Assessment (SCA), Continuous Monitoring (CM), Indication of Compromise (IOC), Policy Compliance (PC), PCI Compliance (PCI), File Integrity Monitoring (FIM), Security Assessment Questionnaire (SAQ), Web Application Scanning (WAS), Web Application Firewall (WAF), Malware Detection (MD), CloudView (CV), Container Security (CS), Asset Inventory ( AI)) and US Platform 3 (CertView (CERT)).