US Platform 1: Slowness Loading PA UI (IM-12655)

Incident Report for Qualys, Inc.

Resolved

This incident has been resolved.
Posted May 18, 2026 - 11:42 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 18, 2026 - 08:18 PDT

Investigating

The Qualys Cloud Platform Operations team is currently investigating an issue affecting the Qualys US Platform 1. As a result, customers may experience slow performance when logging into PA Module may take longer to load.

Further updates will be provided as they become available. The ticket reference for this incident is IM-12655.
Posted May 18, 2026 - 07:01 PDT
This incident affected: US Platform 1 (Policy Audit (PA)).