Update on BrowserCheck Chrome Extension for Windows and Mac
Incident Report for Qualys, Inc.
Resolved
BrowserCheck Chrome Extension for Windows and Mac is getting updated with 64-bit support.
Customers using the current version are advised to remove the extension from Chrome and visit BrowserCheck.Qualys.com website to get the updated extension.
Posted Jul 18, 2018 - 03:38 PDT