US Platform 2: AssetView and Threat Protection QID queries return more results than expected (IM-3236)
Incident Report for Qualys, Inc.
Resolved
This incident has been resolved.
Posted Feb 01, 2020 - 12:19 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 31, 2020 - 14:11 PST
Identified
Qualys Engineering has identified the issue causing QID based AssetView and Threat Protection token based queries to return erroneous results. A patch is being prepared and will be deployed to restore normal behavior.

The example token below can return erroneous results:

vulnerabilities.vulnerability.qid:6

A workaround can be applied by surrounding the sub-token with parentheses as seen below:

vulnerabilities:(vulnerability.qid:6)

Further updates will be provided as soon as they become available.
Posted Jan 30, 2020 - 14:39 PST
Investigating
Qualys Cloud Platform Operations is currently investigating an issue causing QID based AssetView and Threat Protection token based queries to return erroneous results. This could result in AV/TP queries and dashboards returning QID values that were not included in the search.

The example token below can return erroneous results:

vulnerabilities.vulnerability.qid:6

A workaround can be applied by surrounding the sub-token with parentheses as seen below:

vulnerabilities:(vulnerability.qid:6)

Further updates regarding a fix to restore normal behavior will be provided as soon as they become available.
Posted Jan 30, 2020 - 12:23 PST
This incident affected: US Platform 2 (AssetView (AV), Threat Protection (TP)).