All Platforms: Cloud Agent | CDN Resource Expiry Halts New Cloud Agent Activations (IM-12001)

Incident Report for Qualys, Inc.

Resolved

This incident has been resolved.

The required resources have been republished on the CDN, and newly activated agents can now successfully download them. Agents that failed activation due to this issue will need to be deactivated and reactivated to re-trigger the download process.
Posted Mar 29, 2025 - 14:21 PDT

Update

We have implemented a fix and confirmed the restoration of the affected capabilities. Automated test cases have also been deployed to prevent recurrence by ensuring the continued availability of required resources.
Posted Mar 28, 2025 - 20:56 PDT

Identified

The issue has been identified as expired CDN-hosted resources required for activating specific Cloud Agent capabilities. A fix is being implemented to restore availability.
Posted Mar 28, 2025 - 20:38 PDT

Investigating

Qualys Cloud Platform Operations is investigating an issue affecting specific Cloud Agent capabilities, including Software Composition Analysis (SwCA), Cloud Agent Passive Sensor (CAPS), TruRisk Mitigation and Isolation resources from being downloaded. This issue does not impact existing agents but affects newly activated agents for these capabilities. IM-12001 for referance.
Posted Mar 28, 2025 - 20:37 PDT
This incident affected: IN Platform 1 (Cloud Agent (CA), Patch Management (PM)), US Platform 1 (Cloud Agent (CA), Patch Management (PM)), US Platform 2 (Cloud Agent (CA), Patch Management (PM)), EU Platform 1 (Cloud Agent (CA), Patch Management (PM)), US Platform 3 (Cloud Agent (CA)), EU Platform 2 (Cloud Agent (CA), Patch Management (PM)), CA Platform 1 (Cloud Agent (CA), Patch Management (PM)), US Platform 4 (Cloud Agent (CA), Patch Management (PM)), AE Platform 1 (Cloud Agent (CA), Patch Management (PM)), AU Platform 1 (Cloud Agent (CA), Patch Management (PM)), KSA Platform 1 (Cloud Agent (CA), Patch Management (PM)), EU Platform 3 (Cloud Agent (CA), Patch Management (PM)), and UK Platform 1 (Cloud Agent (CA), Patch Management (PM)).